Page 5 of 9 FirstFirst 123456789 LastLast
Results 81 to 100 of 176

Thread: MISSING: Link to the Discussion Forums on the new site!

  1. #81
    Very Active Member gdanner's Avatar
    Join Date
    Jun 2010
    Location
    Fairport, NY
    Posts
    512
    Blog Entries
    608

    Re: MISSING: Link to the Discussion Forums on the new site!

    I would encourage everyone to continue reporting new issues to the national office. If you've already reported your issue to them, then sharing it here might lead to other solutions.

    Quote Originally Posted by swimark View Post
    Chrome workaround (that works for me);
    Once in Chrome, open a new incognito window (Ctrl+Shift+N) and login to USMS. From here I can navigate for a while without any issues - EXCEPT when I go to the forum and log in. Once logged into the forum and come back to the "my USMS" incognito tab I will get the blue screen error. So close all incognito tabs and start over.
    Have you tried logging in on any other devices? It would be useful to note whether your issue is user specific or device specific.

    I've been using the forums/blog/flog on a Windows 10 x64 laptop via Chrome with no issues.
    USMS Secretary
    NI LMSC Chair/Webmaster - http://www.niagaramasters.org

  2. #82
    Participating Member
    Join Date
    May 2014
    Location
    Binghamton, NY
    Posts
    1

    Re: MISSING: Link to the Discussion Forums on the new site!

    Good idea, who should we contact in the national office to report issues? I would like to report a few bugs including:

    1) Intermittent 404 of National Office links

    2) No search option for open water in the events listing

    3) The top-level search function does not perform member search anymore

    I work at a tech company and for new software we tend to have a trouble reporting system, like bugzilla, maybe something similar might be helpful here so the national office doesn't get flooded with calls on the same issues.

  3. #83
    aka Elaine-iaK & Aqua Dog ElaineK's Avatar
    Join Date
    Feb 2010
    Location
    Georgia
    Posts
    4,434

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Andrew F Schaefer View Post
    Good idea, who should we contact in the national office to report issues? I would like to report a few bugs including:

    1) Intermittent 404 of National Office links

    2) No search option for open water in the events listing

    3) The top-level search function does not perform member search anymore

    I work at a tech company and for new software we tend to have a trouble reporting system, like bugzilla, maybe something similar might be helpful here so the national office doesn't get flooded with calls on the same issues.

    As I have stated on this thread a couple of times, please write to Jessica at: membership@usmastersswimming.org . When we spoke on the phone, Jessica specifically asked to contact her there, so she could pass this information on to IT. PLEASE contact her with ALL of your issues, and then post them here as well, as gdanner stated. And, while I'm at it, don't shoot the messenger. Jessica had nothing to do with this FIASCO!
    http://ElaineiaKsTravels.wordpress.com

    ~ Believing in your dreams can be far more rewarding than living by your limitations ~Karla Peterson

  4. #84
    Very Active Member swimark's Avatar
    Join Date
    Nov 2012
    Location
    Pennington, NJ
    Posts
    101

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by gdanner View Post
    I would encourage everyone to continue reporting new issues to the national office. If you've already reported your issue to them, then sharing it here might lead to other solutions.



    Have you tried logging in on any other devices? It would be useful to note whether your issue is user specific or device specific.

    I've been using the forums/blog/flog on a Windows 10 x64 laptop via Chrome with no issues.
    I think I mentioned it before, if not here then in emails\phone calls to USMS.
    Same problems on all these devices;
    Home desktop - Windows 10, Chrome, MS edge;
    Work laptop - Windows 7 Pro, Chrome, MS Internet Explorer;
    Amazon Fire tablet - Chrome, Silk;
    Iphone 8 - Safari.

    No love anywhere

  5. #85
    Very Active Member gdanner's Avatar
    Join Date
    Jun 2010
    Location
    Fairport, NY
    Posts
    512
    Blog Entries
    608

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Andrew F Schaefer View Post
    Good idea, who should we contact in the national office to report issues? I would like to report a few bugs including:

    I work at a tech company and for new software we tend to have a trouble reporting system, like bugzilla, maybe something similar might be helpful here so the national office doesn't get flooded with calls on the same issues.
    They have a ticketing system available, so if they're using it to track bugs/feature requests I wouldn't worry about possible duplicates. Also, the priority level might get raised for an issue if it receives multiple requests.

    Quote Originally Posted by ElaineK View Post

    As I have stated on this thread a couple of times, please write to Jessica at: membership@usmastersswimming.org .
    Thanks for helping the forumites! From what I've heard, the national office is working diligently.

    Quote Originally Posted by swimark View Post
    I think I mentioned it before, if not here then in emails\phone calls to USMS.
    Same problems on all these devices;
    Home desktop - Windows 10, Chrome, MS edge;
    Work laptop - Windows 7 Pro, Chrome, MS Internet Explorer;
    Amazon Fire tablet - Chrome, Silk;
    Iphone 8 - Safari.

    No love anywhere
    Based on that, it sounds like your problem is specifically tied to your account(s), or at least that's the next place I would go with troubleshooting. To test that, you'd either need to try someone else's login on one of your devices (any friends or family who are members?) and see if theirs works and/or create a new MyUSMS account (if one already exists with your info and you can't create a new one, maybe you can ask the national office to delete it) and try logging into that instead.
    USMS Secretary
    NI LMSC Chair/Webmaster - http://www.niagaramasters.org

  6. #86
    Very Active Member knelson's Avatar
    Join Date
    Mar 2003
    Location
    Seattle, WA
    Posts
    8,064
    Blog Entries
    567

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by orca1946 View Post
    OK after using it a few times now, I am getting used to just scrolling waaayyy down to the bottom and finding forums.
    You know you could just set a bookmark.

  7. #87
    aka Elaine-iaK & Aqua Dog ElaineK's Avatar
    Join Date
    Feb 2010
    Location
    Georgia
    Posts
    4,434

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by knelson View Post
    You know you could just set a bookmark.

    A loooong time ago, I logged into the Forums and bookedmarked this page. It has been so long, I had to refer to my password list to look up my password for this page, so I could use the same one on the new website. It's as simple as that! Now that the Forums are on the MY USMS page of the new site, I can go back to the Forums from the new site and not have to log in again. The frustrating thing is that if I go the other way (from the Forums to the new website), I DO have to log in there again (if it's a new day, and the new website didn't hold my login info).

    IT, I already asked this of Jessica when I spoke with her, but PLEASE get that "Remember Me" box added to the new site, so we can check it and not have to log in each time!
    http://ElaineiaKsTravels.wordpress.com

    ~ Believing in your dreams can be far more rewarding than living by your limitations ~Karla Peterson

  8. #88
    aka Elaine-iaK & Aqua Dog ElaineK's Avatar
    Join Date
    Feb 2010
    Location
    Georgia
    Posts
    4,434

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by gdanner View Post
    Thanks for helping the forumites!

    You're welcome, G! I have to watch out for my Forumite Family!
    We need to stick together!!
    http://ElaineiaKsTravels.wordpress.com

    ~ Believing in your dreams can be far more rewarding than living by your limitations ~Karla Peterson

  9. #89
    Very Active Member Mark Usher's Avatar
    Join Date
    Sep 2014
    Location
    Sarasota, FL
    Posts
    116

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Water Rat View Post
    Please tell me this is a beta test site that went live too soon.
    That was my reaction also. Most website updates have glitches, and I hate to be too critical of folks that I am sure are working hard to fix things, but it appears that the new site just wasn't ready to go live. Wonder if they tried running it in parallel to check functionality before going live?
    I've mostly figured out how to get around, but there are still a lot of '404' pages.

  10. #90
    Very Active Member
    Join Date
    Jan 2010
    Location
    PA
    Posts
    773
    Blog Entries
    167

    Re: MISSING: Link to the Discussion Forums on the new site!

    Big improvement in functionality for me today! Lots of links are working that were dead.

  11. #91
    Very Active Member ourswimmer's Avatar
    Join Date
    Aug 2007
    Location
    Oakland, California
    Posts
    584

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Gary P View Post
    To throw something positive out there, the new homepage is a dramatic improvement on mobile browsers.
    I can't find any way to sign in to "My USMS" using my phone, though.

    Quote Originally Posted by jpetyk View Post
    Why oh why is the "Find a Club" so jacked?
    I learned what may be an answer to this question. For some reason, USMS couldn't just populate the "Club Finder" from its own list of registered clubs and workout groups, even though the information is exactly the same information that one would have submitted to register a club or workout group. Instead, they sent email to every registered club's contact person(s) asking those people to resubmit this same information for the "Club Finder." They say they sent this request repeatedly; they may have, but many club contacts may have ignored it because they already had submitted the information in registering their clubs, or missed it as spam, or something else. So the current "Club Finder" reflects only clubs whose contact person(s) answered this request, and not clubs where the request went unanswered.

  12. #92
    Active Member
    Join Date
    Jul 2006
    Location
    Bridgewater, MA
    Posts
    61

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Glenn View Post
    What was wrong with the website that it had to change at all? Sheesh...
    I completely agree. The new site doesn't work on my phone. It is harder to use. What is the point? The old site worked just fine so now they decided to make a new one that is less user friendly. Not good.

    G Shaw

  13. #93
    Very Active Member
    Join Date
    Jan 2011
    Location
    Pittsburgh, PA
    Posts
    269

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by ourswimmer View Post

    For some reason, USMS couldn't just populate the "Club Finder" from its own list of registered clubs and workout groups, even though the information is exactly the same information that one would have submitted to register a club or workout group. Instead, they sent email to every registered club's contact person(s) asking those people to resubmit this same information for the "Club Finder." They say they sent this request repeatedly; they may have, but many club contacts may have ignored it because they already had submitted the information in registering their clubs, or missed it as spam, or something else. So the current "Club Finder" reflects only clubs whose contact person(s) answered this request, and not clubs where the request went unanswered.
    Then they need to find a way to enter the data themselves. The club finder function is woefully inadequate across the board, not just Pittsburgh. The maps a stupid, that's what Google is for. I believe club contacts may have ignored the requests, but that is not a good enough excuse to explain it away. USMS cannot throw up their collective hands and say "oh well, we tried." They are supposed to be supporting the swimmers and the clubs, not the other way around.

  14. #94
    Very Active Member gdanner's Avatar
    Join Date
    Jun 2010
    Location
    Fairport, NY
    Posts
    512
    Blog Entries
    608

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by gshaw View Post
    I completely agree. The new site doesn't work on my phone. It is harder to use. What is the point? The old site worked just fine so now they decided to make a new one that is less user friendly. Not good.

    G Shaw
    Can you elaborate on why it is harder to use or "doesn't work" on your phone?

    By industry standards, the old website did not pass mobile-friendly testing protocols. I ran it against Google's testing site (https://search.google.com/test/mobile-friendly) last summer for an analysis prior to a tech workshop at the annual convention, where I compared the USMS site to many LMSC websites that were already mobile-friendly. Several examples of this include: site not being formatted to the screen size (users needs to pinch to zoom in and out to see things), scrolling had to occur in all directions (up, down, left, and right), and menus not easily traversable. I didn't know it at the time, but the project for the new USMS website was actually already underway. The new site fixed all these issues (and more) for the core website.

    The forums and some other components of the old site present unique integration challenges, which the national office is trying to address.
    USMS Secretary
    NI LMSC Chair/Webmaster - http://www.niagaramasters.org

  15. #95
    Very Active Member mmlr38's Avatar
    Join Date
    Nov 2011
    Location
    Ashland, Oregon
    Posts
    318

    Re: MISSING: Link to the Discussion Forums on the new site!

    I just read through this entire thread. As a web programmer who just about 2 months ago completed a project that was almost exactly the same scope as the USMS website revamp, this thread brings back some (not so great) memories of posts I read from users on that website (SummitPost.org). SummitPost gets quite a bit more traffic than USMS, and the transition to the new site went a little more smoothly, but there was still a fairly large crowd of people who weren't happy at all with the changes.

    Many people on SummitPost had the same question as Glenn: "Why was any change necessary?" As Greg explained, the changes to the USMS website were necessary to make the website mobile-friendly. A few years ago, Google started penalizing websites in their organic search results that weren't mobile friendly by not showing them as high in search results on mobile devices. So this change was absolutely necessary for keeping the USMS website up-to-date and competitive in organic search results so we can attract new members and to make the site more usable on mobile devices.

    However, it does seem like this launch was rushed somewhat and there wasn't sufficient testing on both mobile and desktop devices and different browsers before making the transition. I didn't experience anything that was as frustrating as most people here, even though I primarily use Google Chrome which is reportedly one of the browsers that does not work well with the new site.

    I didn't have any issues with my log in not working. And I was fairly quickly able to figure out most of the navigation options that used to be in the header menu were moved to the footer.

    BUT ONE IMPORTANT THING I FOUND HARD TO USE (and has already been mentioned in this thread) is the calendar of events: https://www.usms.org/events

    It's nice and fancy to geolocate based on IP address and provide a list of events sorted by closest distance to where I live, but that's not at all what I want to see when I go to see a "calendar." I already know of events close to me since there are only a few. I want to see what events fit my schedule anywhere in the country and to figure that out quickly, I need to see them organized chronologically. But I can't sort them chronologically so this "Calendar of Events" is cumbersome and inefficient to use unless you just want to find stuff geographically closest to you.

    And there are some formatting issues on quite a few pages when viewed on mobile as well. See the below screenshots for examples.

    Click image for larger version. 

Name:	Screenshot_20180411-121940.png 
Views:	34 
Size:	186.4 KB 
ID:	11526Click image for larger version. 

Name:	Screenshot_20180411-122001.png 
Views:	32 
Size:	231.8 KB 
ID:	11527

    The first one is my meet results page viewed in portrait mode on my phone. It's really hard to read. Viewed in landscape mode (second screenshot) the formatting is much easier to read. I'd suggest making it so that the tables displaying meet results scroll left and right so that they are more readable instead of trying to squish them into the narrow width of a phone screen.

    There are quite a few other such things on the new USMS website that I'm sure will be addressed in time.

    All in all, I would give the team who did the job a C+ or a B- on the new site. It's certainly not unusable and I can see the logic in most of the changes. More testing on mobile would have been good, but the site is FAR easier to use on a mobile device (for most things) and I'm sure the work will continue to improve it.

    Thank you for all of the work that's gone into it already and I look forward to seeing the site continue to improve.

  16. #96
    Very Active Member Allen Stark's Avatar
    Join Date
    Aug 2002
    Location
    Mulino,OR
    Posts
    4,483

    Re: MISSING: Link to the Discussion Forums on the new site!

    So this is to make it better on mobile devices, but I still cannot access the forums from my phone. Also I found navigating the Nationals site on my phone relatively frustrating.
    "To strive,to seek,to find,and not to yield" Tennyson
    Allen

  17. #97
    Very Active Member mmlr38's Avatar
    Join Date
    Nov 2011
    Location
    Ashland, Oregon
    Posts
    318

    Re: MISSING: Link to the Discussion Forums on the new site!

    Quote Originally Posted by Allen Stark View Post
    I still cannot access the forums from my phone.
    That's odd. I just checked on my phone and it wasn't an issue. Where are you encountering problems? Are you clicking the link on the bottom of the main USMS.org homepage to try to access the forums? If so, what are you seeing when you click that link? Or is it an issue with logging into the forums? If it is an issue with logging in, have you tried clearing all of your browser cache/cookies? That should resolve any login issues.

    Quote Originally Posted by Allen Stark View Post
    Also I found navigating the Nationals site on my phone relatively frustrating.
    In what way? And are you referring to the Nationals portion of the USMS website? Or the Club Assistant registration and Meet Roster pages?

  18. #98
    aka Elaine-iaK & Aqua Dog ElaineK's Avatar
    Join Date
    Feb 2010
    Location
    Georgia
    Posts
    4,434

    Re: MISSING: Link to the Discussion Forums on the new site!

    Fly Trap, I sent a link to your excellent post #96 to Jessica at USMS to pass along to IT. This is what I wrote:

    Hi Jessica,


    I think you should read this post:
    http://forums.usms.org/showthread.ph...l=1#post326479

    No matter how you spin it as being "soft roll-out" or whatever, everybody who has posted on this thread agrees the new website should have gone through more testing.

    Meanwhile, I still see that each day, I have to log in again to the new site, even if I try to navigate there from my bookmarked Forums page. Are they going to add a "Remember me" option, so the site will hold my login information? That seems like a basic and easy task that would alleviate daily frustration.


    Thanks,
    Elaine
    http://ElaineiaKsTravels.wordpress.com

    ~ Believing in your dreams can be far more rewarding than living by your limitations ~Karla Peterson

  19. #99
    Very Active Member mmlr38's Avatar
    Join Date
    Nov 2011
    Location
    Ashland, Oregon
    Posts
    318

    Re: MISSING: Link to the Discussion Forums on the new site!

    Thanks for passing my post along Elaine!

  20. #100
    aka Elaine-iaK & Aqua Dog ElaineK's Avatar
    Join Date
    Feb 2010
    Location
    Georgia
    Posts
    4,434

    Re: MISSING: Link to the Discussion Forums on the new site!

    You're welcome, Fly Trap! This is Jessica's response (it was quick!):

    HI Elaine thank you as always for the feedback.

    As functionality issues are submitted/reported we are prioritizing them and working towards addressing and resolving. (some will take longer than others)

    Extensive testing was done prior to launch, and as many have noted in the thread when I last read, hiccups are to be expected with any website roll-out. We would not have been able to identify the breaks without launching and receive the real-time feedback, which we have been tirelessly working on resolving. I hope forum posters have also been posting about the things that have been fixed after they have been reported in addition to their other feedback.

    As I mentioned on our call we did not launch the site to upset members and vested volunteers by any means. It does have a completely new look and information is in different places, which is disruptive to those who frequently use the site, especially from your levels of involvement, and knew exactly where everything was for the past 20+ years. I completely understand where the frustrations are coming from. (I hope you understand it is not easy on my end either)

    Please know we are doing everything we can to make sure the functionalities that are being brought to our attention are being addressed, and hope to have the site functioning to its full potential.

    -Jessica

    Jessica Porter
    Senior Director, Membership Acquisition & Services | U.S. Masters Swimming
    1751 Mound Street, Suite 201 | Sarasota, FL 34236
    (941) 556-6275 | JPorter@USMastersSwimming.org
    usms.org | Facebook
    http://ElaineiaKsTravels.wordpress.com

    ~ Believing in your dreams can be far more rewarding than living by your limitations ~Karla Peterson

Page 5 of 9 FirstFirst 123456789 LastLast

Similar Threads

  1. Easier Access to Discussion Forums
    By amj119 in forum Workouts
    Replies: 4
    Last Post: November 27th, 2014, 12:13 PM
  2. Missing link from Nationals page
    By mattson in forum Nationals
    Replies: 12
    Last Post: May 30th, 2008, 05:32 PM
  3. Great Discussion Forums
    By Swimmer1999 in forum General Swimming-Related Discussions
    Replies: 6
    Last Post: July 21st, 2005, 12:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •